[Buildroot] [PATCH 2/2] package/mesa3d: get glxgears working for v3d/vc4 minimal builds

Peter Seiderer ps.report at gmx.net
Fri Mar 6 14:38:54 UTC 2020


Hello Howard,

On Fri,  6 Mar 2020 09:25:04 +0000, Howard Mitchell <hm at hmbedded.co.uk> wrote:

> Currently a minimal build for rpi2/3/4 (i.e. only v3d and/or vc4
> selected, no dri drivers selected) results in working X11 except that
> glxgears shows a blank window. This commit effectively results in the
> following conf options being added: -Dglx-direct=true -Ddri3=true
>
> Signed-off-by: Howard Mitchell <hm at hmbedded.co.uk>
> ---
>  package/mesa3d/Config.in | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/package/mesa3d/Config.in b/package/mesa3d/Config.in
> index 3950170533..59b8f60773 100644
> --- a/package/mesa3d/Config.in
> +++ b/package/mesa3d/Config.in
> @@ -274,6 +274,7 @@ config BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_VC4
>  	select BR2_PACKAGE_MESA3D_GALLIUM_KMSRO
>  	select BR2_PACKAGE_LIBDRM_VC4
>  	select BR2_PACKAGE_MESA3D_OPENGL_EGL
> +	select BR2_PACKAGE_MESA3D_DRI_DRIVER

On rpi4 v3d/vc4 work definitely for the Qt/eglfs case without
MESA3D_DRI_DRIVER, so this should at minimum depend on X11 (or
only be selected by x11/glxgears)?

Regards,
Peter

>  	help
>  	  Driver for Broadcom VC4 (rpi2/3) GPUs.
>  	  It requires a vanilla 4.5+ kernel with drm vc4 (open) support.



More information about the buildroot mailing list