[Buildroot] [PATCH 5/5] package/gcc: switch to gcc 9.x as the default

Thomas Petazzoni thomas.petazzoni at bootlin.com
Wed Jun 24 19:56:54 UTC 2020


On Tue,  9 Jun 2020 00:13:47 +0200
Romain Naour <romain.naour at gmail.com> wrote:

> Even if gcc 8 is still maintained for some time (gcc 8.5 is pending),
> switch to gcc 9.x since it has been released since 2019-05-03 and
> gcc 10.x is available since 2020-05-07.
> 
> We have been having toolchains in the autobuilders with gcc
> 9.x for a while, so the vast majority of the problems should have
> already been solved.
> 
> Signed-off-by: Romain Naour <romain.naour at gmail.com>
> ---
>  package/gcc/Config.in.host | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied to master, thanks.

Following this, we should drop gcc 7.x support. However, one defconfig
(roseapplepi) still uses gcc 7.x. I've notified Peter Korsgaard on IRC,
and I am doing it here as well: if this defconfig is not updated to a
newer kernel that builds with gcc >= 8.x, we will have to drop support
for this defconfig.

Thomas
-- 
Thomas Petazzoni, CTO, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com


More information about the buildroot mailing list