[Buildroot] [PATCH] package/ethtool: bump to 5.6

Thomas Petazzoni thomas.petazzoni at bootlin.com
Tue Jun 2 20:16:15 UTC 2020


On Tue,  2 Jun 2020 07:03:36 -0500
Matt Weber <matthew.weber at rockwellcollins.com> wrote:

>  * New dependency was added on libmnl (netlink library)
>  * Now requires an updated pkg-config

libmnl is not required. From configure.ac:

AC_ARG_ENABLE(netlink,
              [  --enable-netlink         enable netlink interface (enabled by default)],
              ,
              enable_netlink=yes)
if test x$enable_netlink = xyes; then
    PKG_PROG_PKG_CONFIG
    PKG_CHECK_MODULES([MNL], [libmnl])
    AC_DEFINE(ETHTOOL_ENABLE_NETLINK, 1,
              Define this to support netlink interface to talk to kernel.)
fi

So what we need is:

ifeq ($(BR2_PACKAGE_LIBMNL),y)
ETHTOOL_DEPENDENCIES += host-pkgconf libmnl
ETHTOOL_CONF_OPTS += --enable-netlink
else
ETHTOOL_CONF_OPTS += --disable-netlink
endif

Thanks!

Thomas
-- 
Thomas Petazzoni, CTO, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com


More information about the buildroot mailing list