[Buildroot] [PATCH 3/9 v2] package/prosody: don't depend on !lua 5.3

Yann E. MORIN yann.morin.1998 at free.fr
Mon Jul 27 20:32:54 UTC 2020


From: James Hilliard <james.hilliard1 at gmail.com>

The current version of prosody is compatible with Lua 5.3.

Signed-off-by: James Hilliard <james.hilliard1 at gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998 at free.fr>
---
 package/prosody/Config.in | 4 ----
 1 file changed, 4 deletions(-)

diff --git a/package/prosody/Config.in b/package/prosody/Config.in
index c32ca20e23..4b7ea94256 100644
--- a/package/prosody/Config.in
+++ b/package/prosody/Config.in
@@ -2,7 +2,6 @@ config BR2_PACKAGE_PROSODY
 	bool "prosody"
 	depends on BR2_USE_MMU # fork
 	depends on BR2_PACKAGE_HAS_LUAINTERPRETER
-	depends on !BR2_PACKAGE_LUA_5_3
 	depends on !BR2_STATIC_LIBS # luaexpat, luasec, luasocket, luafilesystem
 	select BR2_PACKAGE_LUABITOP if !BR2_PACKAGE_LUAJIT # runtime
 	select BR2_PACKAGE_LUAEXPAT # runtime
@@ -21,6 +20,3 @@ config BR2_PACKAGE_PROSODY
 comment "prosody needs the lua interpreter, dynamic library"
 	depends on !BR2_PACKAGE_HAS_LUAINTERPRETER || BR2_STATIC_LIBS
 	depends on BR2_USE_MMU
-
-comment "prosody needs a Lua 5.1/5.2 interpreter"
-	depends on BR2_PACKAGE_LUA_5_3
-- 
2.20.1



More information about the buildroot mailing list