[Buildroot] [PATCH 2/2] package/libgsasl: enable gcrypt support

Fabrice Fontaine fontaine.fabrice at gmail.com
Sat Jul 25 10:18:29 UTC 2020


Signed-off-by: Fabrice Fontaine <fontaine.fabrice at gmail.com>
---
 package/libgsasl/libgsasl.mk | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/package/libgsasl/libgsasl.mk b/package/libgsasl/libgsasl.mk
index 0cec9c73bd..40e7c4c918 100644
--- a/package/libgsasl/libgsasl.mk
+++ b/package/libgsasl/libgsasl.mk
@@ -9,8 +9,13 @@ LIBGSASL_SITE = $(BR2_GNU_MIRROR)/gsasl
 LIBGSASL_LICENSE = LGPL-2.1+ (library), GPL-3.0+ (programs)
 LIBGSASL_LICENSE_FILES = README COPYING.LIB COPYING
 LIBGSASL_INSTALL_STAGING = YES
-# It doesn't seem to build with our libgcrypt so better be safe
+
+ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
+LIBGSASL_CONF_OPTS = --with-libgcrypt-prefix=$(STAGING_DIR)/usr
+LIBGSASL_DEPENDENCIES += libgcrypt
+else
 LIBGSASL_CONF_OPTS = --without-libgcrypt
+endif
 
 ifeq ($(BR2_PACKAGE_LIBIDN),y)
 LIBGSASL_CONF_OPTS += --with-libidn-prefix=$(STAGING_DIR)/usr
-- 
2.27.0



More information about the buildroot mailing list