[Buildroot] [PATCH 1/1] package/connman: bump to 1.38

Thomas Petazzoni thomas.petazzoni at bootlin.com
Wed Feb 26 21:26:26 UTC 2020


Hello Petr,

On Thu, 20 Feb 2020 00:16:16 +0100
Petr Vorel <petr.vorel at gmail.com> wrote:

> This release requires libmnl (WireGuard dependency).
> 
> Signed-off-by: Petr Vorel <petr.vorel at gmail.com>

My reading of configure.ac is that it doesn't require libmnl. It only
needs it if WireGuard support is enabled:

found_libmnl="no"
if (test "${firewall_type}" = "nftables" -o \
                "${enable_wireguard}" != "no"); then
        PKG_CHECK_MODULES(LIBMNL, [libmnl >= 1.0.0], [found_libmnl="yes"],
                AC_MSG_ERROR([libmnl >= 1.0.0 not found]))
        AC_SUBST(LIBMNL_CFLAGS)
        AC_SUBST(LIBMNL_LIBS)
fi
AM_CONDITIONAL(LIBMNL, test "${found_libmnl}" != "no")

The connman package probably needs to be extended to support either
iptables or nftables as firewall types, and other options to
enable/disable wireguard support.

Thanks!

Thomas
-- 
Thomas Petazzoni, CTO, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com


More information about the buildroot mailing list