[Buildroot] [PATCH v2 01/37] package/qt5: drop 5.6 support

Peter Korsgaard peter at korsgaard.com
Wed Feb 26 15:25:02 UTC 2020


>>>>> "Peter" == Peter Korsgaard <peter at korsgaard.com> writes:

 > As discussed during the FOSDEM2019 develop days, Qt 5.6 is very old (5.6.3
 > was released in September 2017, and 5.6.x became EOL in March 2019), so drop
 > it before the new Buildroot LTS release:

 > https://elinux.org/Buildroot:DeveloperDaysFOSDEM2019#Qt5_versions_to_support:_keep_5.6_or_a_newer_LTS.3F

 > And add legacy handling for it.

 > There are a number of places where code checks for
 > BR2_PACKAGE_QT5_VERSION_LATEST, so leave that as a blind option for now to
 > not break the build.

 > Signed-off-by: Peter Korsgaard <peter at korsgaard.com>
 > ---
 > Changes since v1:
 > - Leave BR2_PACKAGE_QT5_VERSION_LATEST as a blind option for
 >   bisectability

Committed, thanks.

The rest of the series is not strictly needed for master, so I will
apply the series to next instead.

If it doesn't blow up / needed, it can then later be applied to master
as well.

-- 
Bye, Peter Korsgaard


More information about the buildroot mailing list