[Buildroot] [PATCH 1/4] package/webkitgtk: needs >= GCC 7

Peter Korsgaard peter at korsgaard.com
Sun Feb 16 11:55:37 UTC 2020


>>>>> "Peter" == Peter Korsgaard <peter at korsgaard.com> writes:

 > CMakeLists.txt contains a toolchain check:
 > if (${CMAKE_CXX_COMPILER_ID} STREQUAL "GNU")
 >     if (${CMAKE_CXX_COMPILER_VERSION} VERSION_LESS "7.3.0")
 >         message(FATAL_ERROR "GCC 7.3 or newer is required to build WebKit. Use a newer GCC version or Clang.")
 >     endif ()
 > endif ()

 > So bump the toolchain dependency to >= GCC 7.  The check is really about >=
 > 7.3.0, but we do not have such detailed version checks.  Given that GCC
 > 7.3.0 was released in January 2018 (and 7.1.0 in May 2017), most external
 > GCC 7.x toolchains probably use >= 7.3.0.

 > Signed-off-by: Peter Korsgaard <peter at korsgaard.com>

Committed, thanks.

-- 
Bye, Peter Korsgaard


More information about the buildroot mailing list