[Buildroot] [git commit] package/libnice: drop gstreamer 0.10.x support

Yann E. MORIN yann.morin.1998 at free.fr
Sat Feb 8 21:42:43 UTC 2020


commit: https://git.buildroot.net/buildroot/commit/?id=8be6732792019aef890c8ec4d88e52548ff5f711
branch: https://git.buildroot.net/buildroot/commit/?id=refs/heads/master

With the upcoming removal of gstreamer 0.10, the logic for building
libnice with support for it must go as well.

Signed-off-by: Peter Korsgaard <peter at korsgaard.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998 at free.fr>
---
 package/libnice/libnice.mk | 8 +-------
 1 file changed, 1 insertion(+), 7 deletions(-)

diff --git a/package/libnice/libnice.mk b/package/libnice/libnice.mk
index b5168f83ed..8cbf003529 100644
--- a/package/libnice/libnice.mk
+++ b/package/libnice/libnice.mk
@@ -10,6 +10,7 @@ LIBNICE_LICENSE = MPL-1.1 or LGPL-2.1
 LIBNICE_LICENSE_FILES = COPYING COPYING.MPL COPYING.LGPL
 LIBNICE_DEPENDENCIES = libglib2 host-pkgconf
 LIBNICE_INSTALL_STAGING = YES
+LIBNICE_CONF_OPTS = --without-gstreamer-0.10
 
 ifeq ($(BR2_PACKAGE_GNUTLS),y)
 LIBNICE_CONF_OPTS += --with-crypto-library=gnutls
@@ -21,13 +22,6 @@ LIBNICE_CONF_OPTS += \
 LIBNICE_DEPENDENCIES += openssl
 endif
 
-ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE),y)
-LIBNICE_CONF_OPTS += --with-gstreamer-0.10
-LIBNICE_DEPENDENCIES += gst-plugins-base
-else
-LIBNICE_CONF_OPTS += --without-gstreamer-0.10
-endif
-
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BASE),y)
 LIBNICE_CONF_OPTS += --with-gstreamer
 LIBNICE_DEPENDENCIES += gst1-plugins-base


More information about the buildroot mailing list