[Buildroot] [PATCH 01/10] package/classpath: drop gstreamer 0.10.x support

Peter Korsgaard peter at korsgaard.com
Fri Feb 7 14:50:16 UTC 2020


With the upcoming removal of gstreamer 0.10, the logic for building
classpath with support for it must go as well.

Signed-off-by: Peter Korsgaard <peter at korsgaard.com>
---
 package/classpath/classpath.mk | 11 ++---------
 1 file changed, 2 insertions(+), 9 deletions(-)

diff --git a/package/classpath/classpath.mk b/package/classpath/classpath.mk
index 6bba6948c5..7177bbfe06 100644
--- a/package/classpath/classpath.mk
+++ b/package/classpath/classpath.mk
@@ -12,6 +12,7 @@ CLASSPATH_CONF_OPTS = \
 	--disable-Werror \
 	--disable-gconf-peer \
 	--disable-gjdoc \
+	--disable-gstreamer-peer \
 	--enable-tools
 
 # classpath assumes qt runs on top of X11, but we
@@ -40,16 +41,8 @@ endif
 ifeq ($(BR2_PACKAGE_LIBGTK2)$(BR2_PACKAGE_XORG7),yy)
 CLASSPATH_CONF_OPTS += --enable-gtk-peer
 CLASSPATH_DEPENDENCIES += libgtk2
-
-ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE),y)
-CLASSPATH_CONF_OPTS += --enable-gstreamer-peer
-CLASSPATH_DEPENDENCIES += gst-plugins-base
-else
-CLASSPATH_CONF_OPTS += --disable-gstreamer-peer
-endif
-
 else
-CLASSPATH_CONF_OPTS += --disable-gtk-peer --disable-gstreamer-peer
+CLASSPATH_CONF_OPTS += --disable-gtk-peer
 endif
 
 ifeq ($(BR2_PACKAGE_LIBXML2)$(BR2_PACKAGE_LIBXSLT)$(BR2_TOOLCHAIN_HAS_THREADS),yyy)
-- 
2.20.1



More information about the buildroot mailing list