[Buildroot] [PATCH 1/3] package/python-iniparse: bump to version 0.5

Thomas Petazzoni thomas.petazzoni at bootlin.com
Wed Feb 5 15:42:50 UTC 2020


On Wed,  5 Feb 2020 15:11:47 +0100
Titouan Christophe <titouan.christophe at railnova.eu> wrote:

> Also, iniparse now requires six.
> This has been detected thanks to the runtime tests.

It would have been good to mention in the commit log that it now supports Python 3.

>  config BR2_PACKAGE_PYTHON_INIPARSE
>  	bool "python-iniparse"
> -	depends on BR2_PACKAGE_PYTHON
> +	depends on BR2_PACKAGE_PYTHON || BR2_PACKAGE_PYTHON3

This is not needed when both are supported, since Python modules
Config.in files are only included when python || python3, from
package/Config.in.

Applied with the above issues fixed. Thanks!

Thomas
-- 
Thomas Petazzoni, CTO, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com


More information about the buildroot mailing list