[Buildroot] [PATCH v15 2/5] package/qemu: do not support x86_steamroller or x86_core_avx2

Adam Duskett aduskett at gmail.com
Tue Feb 4 21:39:53 UTC 2020


These CPU's cause segfaults with qemu.

Signed-off-by: Adam Duskett <aduskett at gmail.com>
---
Changes v1 -> v15:
  - Add this patch to the series

 package/qemu/Config.in.host | 1 +
 1 file changed, 1 insertion(+)

diff --git a/package/qemu/Config.in.host b/package/qemu/Config.in.host
index d6b4bf6dd4..ea9281c5fb 100644
--- a/package/qemu/Config.in.host
+++ b/package/qemu/Config.in.host
@@ -20,6 +20,7 @@ config BR2_PACKAGE_HOST_QEMU_ARCH_SUPPORTS
 	default y if BR2_sparc64
 	default y if BR2_xtensa
 	default y if BR2_x86_64
+	depends on !BR2_x86_steamroller && !BR2_x86_core_avx2
 	depends on !BR2_powerpc_620 && !BR2_powerpc_630 && !BR2_powerpc_970
 
 config BR2_PACKAGE_HOST_QEMU_SYSTEM_ARCH_SUPPORTS
-- 
2.24.1



More information about the buildroot mailing list