[Buildroot] [PATCH 1/1] package/sconeserver: add all blue5_utils dependencies

Fabrice Fontaine fontaine.fabrice at gmail.com
Tue Feb 4 17:58:47 UTC 2020


Commit 61a813339af43024ec05e749a05886fff1bf2a39 forgot to add all the
bluez5_utils dependencies

Signed-off-by: Fabrice Fontaine <fontaine.fabrice at gmail.com>
---
 package/sconeserver/Config.in | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)

diff --git a/package/sconeserver/Config.in b/package/sconeserver/Config.in
index 049d98123e..a42abd70b7 100644
--- a/package/sconeserver/Config.in
+++ b/package/sconeserver/Config.in
@@ -48,13 +48,17 @@ config BR2_PACKAGE_SCONESERVER_BLUETOOTH
 	depends on BR2_USE_MMU # bluez5_utils -> dbus
 	depends on BR2_TOOLCHAIN_HAS_THREADS # bluez5_utils -> dbus, libglib2
 	depends on !BR2_STATIC_LIBS # bluez5_utils
+	depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_4 # bluez5_utils
+	depends on BR2_TOOLCHAIN_HAS_SYNC_4 # bluez5_utils
 	select BR2_PACKAGE_BLUEZ5_UTILS
 	help
 	  Bluetooth module for Sconeserver
 
-comment "bluetooth support needs a toolchain w/ wchar, threads, dynamic library"
+comment "bluetooth support needs a toolchain w/ wchar, threads, dynamic library, headers >= 3.4"
 	depends on BR2_USE_MMU
-	depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
+	depends on BR2_TOOLCHAIN_HAS_SYNC_4
+	depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS || \
+		BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_4
 
 config BR2_PACKAGE_SCONESERVER_RSS
 	bool "rss"
-- 
2.24.1



More information about the buildroot mailing list