[Buildroot] [PATCH 1/2] package/liboping: remove -Werror build flag

Peter Korsgaard peter at korsgaard.com
Mon Feb 3 21:11:35 UTC 2020


>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice at gmail.com> writes:

Hi,

 >> > Can you be more specific on the build failure? For example, by
 >> > providing a link on autobuilder?
 >> > Otherwise, I would prefer an upstreamable solution such as adding a
 >> > --disable-werror option or adding a patch that fixes the issue.
 >> > There is a pending PR on a truncation error on upstream github:
 >> > https://github.com/octo/liboping/pull/50.
 >> > Is it related to your build failure? In this case, I would suggest to
 >> > retrieve this commit.
 >> 
 >> The error is detailed in the Gentoo bug linked above, and this was their
 >> fix for it. There is one single build failure on the autobuilders, and
 >> it's got the same error:
 >> http://autobuild.buildroot.org/?reason=liboping-1.10.0
 > This error was raised in December 5th 2018 and has been fixed by
 > retrieving an upstream commit instead of disabling -Werror (see
 > https://patchwork.ozlabs.org/patch/1009066).
 > There was no more autobuilder failures after this patch was applied.
 > So this is strange that you still get a failure on your local machine.
 > Are you using the master branch or one of the official release (fix
 > was committed to 2018.08.x and 2018.11.x releases)?

Any comments on that? In the mean time I have marked the patch as not
applicable in patchwork.

-- 
Bye, Peter Korsgaard


More information about the buildroot mailing list