[Buildroot] [PATCH 1/2] package/uboot-tools: needs make >= 4.0

Peter Korsgaard peter at korsgaard.com
Mon Feb 3 20:30:52 UTC 2020


>>>>> "Yann" == Yann E MORIN <yann.morin.1998 at free.fr> writes:

 > Starting with 2020.01, uboot started using the 'undefine' make
 > directive, which was only introduced with make 4.0.

 > So, use the existing $(BR2_MAKE_HOST_DEPENDENCY) and $(BR2_MAKE),
 > both of each will ensure that we do use a make that is at least 4.0.

 > Fixes:
 >     http://autobuild.buildroot.org/results/c97/c976ed5eb7760cba192d22b3f1e7460596fd82dd/

 > Reported-by: Peter Korsgaard <peter at korsgaard.com>
 > Signed-off-by: Yann E. MORIN <yann.morin.1998 at free.fr>
 > ---
 >  package/uboot-tools/uboot-tools.mk | 9 ++++++---
 >  1 file changed, 6 insertions(+), 3 deletions(-)

 > diff --git a/package/uboot-tools/uboot-tools.mk b/package/uboot-tools/uboot-tools.mk
 > index 1f0bac5bf7..98ac71911b 100644
 > --- a/package/uboot-tools/uboot-tools.mk
 > +++ b/package/uboot-tools/uboot-tools.mk
 > @@ -11,6 +11,9 @@ UBOOT_TOOLS_LICENSE = GPL-2.0+
 >  UBOOT_TOOLS_LICENSE_FILES = Licenses/gpl-2.0.txt
 >  UBOOT_TOOLS_INSTALL_STAGING = YES
 
 > +UBOOT_TOOLS_DEPENDENCIES = $(BR2_MAKE_HOST_DEPENDENCY)
 > +HOST_UBOOT_TOOLS_DEPENDENCIES = $(BR2_MAKE_HOST_DEPENDENCY)

I added a comment explaining why we are doing this and committed,
thanks.

-- 
Bye, Peter Korsgaard


More information about the buildroot mailing list