[Buildroot] [PATCH 1/1] set minimum cmake version to 3.10

Peter Korsgaard peter at korsgaard.com
Mon Feb 3 15:13:46 UTC 2020


>>>>> "Adam" == Adam Duskett <aduskett at gmail.com> writes:

 > The CMakeLists.txt file uses the CMP0091 which is an MSVC runtime library flag
 > abstraction macro.

 > Because we are not building ninja for Microsoft, it is safe to remove this
 > macro and set the minimum version to 3.10.

There's unfortunately still another issue:

http://autobuild.buildroot.net/results/615/6150430d396b74a81be87d942ca571c7c15dfc52/build-end.log

CMakeLists.txt hardcodes -fdiagnostic-color, which is only supported
from gcc 4.9, breaking builds on old autobuilders:

https://gcc.gnu.org/gcc-4.9/changes.html

We don't really care about coloured error messages, so I guess we can
just patch away that line.

Care to send a patch doing that?

-- 
Bye, Peter Korsgaard


More information about the buildroot mailing list