[Buildroot] [PATCH v4 15/15] package/gcc: enable gcc 9.1 for ork1 (openrisc)

Guo Ren guoren at kernel.org
Sun Jul 14 09:18:59 UTC 2019


On Sun, Jul 14, 2019 at 4:41 PM Yann E. MORIN <yann.morin.1998 at free.fr> wrote:
>
> Guo, All,
>
> On 2019-07-14 07:57 +0800, Guo Ren spake thusly:
> > On Sun, Jul 14, 2019 at 5:24 AM Arnout Vandecappelle <arnout at mind.be> wrote:
> > > On 20/06/2019 12:07, Giulio Benetti wrote:
> > > > openrisc support has been added with gcc 9.1.
> > > > Keep for now the old gcc 5 fork for ork1.
> > >  So, when will we remove this?
> > >  Same for ARC (GCC 8.x fork) and C-SKY (GCC 6.x fork): they are available in
> > > GCC9, do we need to keep those old forks?
> > Keep the fork for C-SKY, the upstream of csky backend in gcc9 only
> > support abiv2.
>
> As far as I can see, we have no way to choose the ABI in Buildroot.
> So, what would we loose by keeping only gcc-9?
See package/Makefile.in

# For C-SKY abiv1 & abiv2
ifeq ($(BR2_csky),y)
ifeq ($(BR2_ck610),y)
ABI = abiv1
else
ABI = abiv2
endif
endif

gcc-9 don't support 610.


-- 
Best Regards
 Guo Ren

ML: https://lore.kernel.org/linux-csky/


More information about the buildroot mailing list