[Buildroot] [PATCH 1/1] package/python-scapy3k: remove package

Thomas Petazzoni thomas.petazzoni at bootlin.com
Sun Dec 8 21:18:36 UTC 2019


On Tue,  3 Dec 2019 23:28:32 +0000
gpotter2 <gabriel at potter.fr> wrote:

> Scapy3k is deprecated since Scapy supports Python 3.
> Scapy should be used instead
> 
> See https://bugs.busybox.net/show_bug.cgi?id=12376
> 
> Signed-off-by: Gabriel Potter <gabriel at potter.fr>
> ---
>  Config.in.legacy                           |  6 ++++++
>  package/Config.in                          |  1 -
>  package/python-scapy3k/Config.in           |  9 ---------
>  package/python-scapy3k/python-scapy3k.hash |  2 --
>  package/python-scapy3k/python-scapy3k.mk   | 12 ------------
>  5 files changed, 6 insertions(+), 24 deletions(-)
>  delete mode 100644 package/python-scapy3k/Config.in
>  delete mode 100644 package/python-scapy3k/python-scapy3k.hash
>  delete mode 100644 package/python-scapy3k/python-scapy3k.mk
> 
> diff --git a/Config.in.legacy b/Config.in.legacy
> index 02886bff36..dfe7683a42 100644
> --- a/Config.in.legacy
> +++ b/Config.in.legacy
> @@ -146,6 +146,12 @@ endif
>  
>  comment "Legacy options removed in 2020.02"
>  
> +config BR2_PACKAGE_PYTHON_SCAPY3K
> +	bool "scapy3k was removed"
> +	select BR2_LEGACY

I've added a:

	select BR2_PACKAGE_PYTHON_SCAPY

here.

> +	help
> +	  scapy3k has been deprecated since Scapy gained Python 3 support. Use BR2_PACKAGE_PYTHON_SCAPY instead

This line was too long ("make check-package" warns about it), and I've
rephrased slightly.

Applied with those changes. Thanks!

Thomas
-- 
Thomas Petazzoni, CTO, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com


More information about the buildroot mailing list