[Buildroot] [PATCH 3/4] package/python-twisted: add config for HTTP2 support

aduskett at gmail.com aduskett at gmail.com
Thu Dec 5 22:15:14 UTC 2019


From: Adam Duskett <Aduskett at gmail.com>

Add an option that selects all of the necessary python packages to ensure that
twisted has HTTP2 support.

Signed-off-by: Adam Duskett <Aduskett at gmail.com>
---
 package/python-twisted/Config.in | 5 +++++
 1 file changed, 5 insertions(+)

diff --git a/package/python-twisted/Config.in b/package/python-twisted/Config.in
index f3d94c544e..767e690e5f 100644
--- a/package/python-twisted/Config.in
+++ b/package/python-twisted/Config.in
@@ -15,6 +15,11 @@ config BR2_PACKAGE_PYTHON_TWISTED
 
 if BR2_PACKAGE_PYTHON_TWISTED
 
+config BR2_PACKAGE_PYTHON_TWISTED_HTTP2
+	bool "HTTP2 support"
+	select BR2_PACKAGE_PYTHON_PRIORITY # runtime
+	select BR2_PACKAGE_PYTHON_H2 # runtime
+
 config BR2_PACKAGE_PYTHON_TWISTED_TLS
 	bool "TLS support"
 	depends on BR2_INSTALL_LIBSTDCPP # python-pyopenssl, python-cryptography
-- 
2.23.0



More information about the buildroot mailing list