[Buildroot] [PATCH v1 3/4] package/docker-engine: bump to 19.03.5

Christian Stewart christian at paral.in
Thu Dec 5 00:28:46 UTC 2019


Hi Peter,

Peter Korsgaard <peter at korsgaard.com> writes:

>>>>>> "Christian" == Christian Stewart <christian at paral.in> writes:
>  >  delete mode 100644 package/docker-engine/0001-Fix-faulty-runc-version-commit-scrape.patch
>
> Next to the text cases pointed out by Thomas, a more detailed commit
> message would be great - E.G. what happened to your patch that you are
> now dropping? Did it get applied upstream? Is it no longer needed? If
> so, why?

It's a really minor patch, I don't think anyone would care really that
it was dropped. I will be sure to mention it in future commit messages
(or if I need to submit a revision for this).

> I don't really understand the relation between containerd and runc, but
> containerd seems to bundle runc? If we backport runc to 2019.02.x do we
> then also need to backport containerd?

The "runc" package in Buildroot compiles the userspace binary "runc"
which is called by "containerd" at runtime to start namespaced processes
(aka containers). "runc" means "run container."

The "runc" version referenced in containerd is the client for the runc
binary and the interfaces between. Matching the expected versions to
each other is necessary but security releases should be compatible.

> According to https://github.com/opencontainers/runc/releases, this is a
> security bump so it should be marked as such and we presumably want to
> backport it to 2019.02.x even though that uses docker 18.09?

Not sure on this one.

Best regards,
Christian


More information about the buildroot mailing list