[Buildroot] [PATCH 1/1] package/libftdi1: fix license

Peter Korsgaard peter at korsgaard.com
Tue Dec 3 12:20:53 UTC 2019


>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice at gmail.com> writes:

 > The GPL only applies to the C++ bindings, which are conditionally
 > enabled with BR2_PACKAGE_LIBFTDI1_LIBFTDIPP1.

 > The COPYING.LIB is indeed the LGPL-2.0, but the source file for
 > libftdi1 states LGPL-2.1-only, see src/ftdi.c

 > The src/ftdi_stream.c also bears a notice of the MIT license, so the
 > library itself is under both LGPL-2.1-only and MIT.

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice at gmail.com>

Committed to 2019.02.x and 2019.08.x, thanks.

-- 
Bye, Peter Korsgaard


More information about the buildroot mailing list