[Buildroot] [PATCH] package/android-tools: fix static build failure due to missing -latomic

Thomas Petazzoni thomas.petazzoni at bootlin.com
Mon Apr 8 07:18:20 UTC 2019


Hello Giulio,

On Sun, 7 Apr 2019 23:55:38 +0200
Giulio Benetti <giulio.benetti at micronovasrl.com> wrote:

> >> -LIBS+= -lc -lpthread -lz -lcrypto -lcrypt `pkg-config --libs glib-2.0 gio-2.0`  
> 
> In current version there is not glib-2.0 or gio-2.0, do I add them 
> anyway as follows?

Wow, I got confused about this. pkg-config is used for glib-2.0 and
gio-2.0 in the upstream android-tools code, but we remove that in our
0002-Fix-adbd-for-non-Ubuntu-systems.patch patch.

So of course, don't re-add those pkg-config calls for glib-2.0 and gio-2.0.

However, use pkg-config for OpenSSL. This will also allow you to drop
patch 0005-fix-static-link-zlib.patch, which was needed for the same
reason: pkg-config is not used to find OpenSSL.

Thanks!

Thomas
-- 
Thomas Petazzoni, CTO, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com


More information about the buildroot mailing list