[Buildroot] [PATCH 1/1] sdl: fix building on powerpc64 and powerpc64le

Sam Bobroff sam.bobroff at au1.ibm.com
Tue Nov 8 05:10:06 UTC 2016


On Tue, Nov 08, 2016 at 02:04:31AM +0100, Arnout Vandecappelle wrote:
> 
> 
> On 07-11-16 22:51, Thomas Petazzoni wrote:
> > Also, are we going to need to patch libtool.m4 in each and every
> > package around? libtool.m4 from sdl is from libtool 2.2 which is not
> > _that_ old (by the standards of libtool upgrade speed, of course), so
> > we're likely to find many other packages in the same situation, aren't
> > we?

>From the libtool git history it looks like the issue is fixed after
libtool 2.4.2.418.

>  Let me rephrase this.
> 
>  You should actually update support/libtool/buildroot-libtool-v1.5.patch and
> support/libtool/buildroot-libtool-v2.2.patch which will fix all packages in one
> fell swoop. (That is, assuming that v2.4 is OK already.)

That sounds great, but that system seems to be set up to patch only
ltmain.sh, and the code that needs patching isn't there.

The change needs to be in aclocal/libtool.m4  but I can't patch that and
then propagate the change to configure, because AUTORECONF doesn't work
for that package. (Maybe it would work for other packages, but I suspect
there would be problems updating a single file on it's own.)

I suppose I could try auto-patching configure and/or configure.in (or
.ac) along the same lines as ltmain.sh... what do you think?

Cheers,
Sam.



More information about the buildroot mailing list