[Buildroot] [PATCH v2] apitrace: new package

Peter Korsgaard jacmet at uclibc.org
Fri Jan 10 22:55:42 UTC 2014


>>>>> "Jérôme" == Jérôme Pouiller <jezz at sysmic.org> writes:

 > Trace and replay OpenGL and OpenGL ES APIs calls to/from a file.
 > http://apitrace.github.io/

 > Signed-off-by: Jérôme Pouiller <jezz at sysmic.org>
 > ---
 > v2:
 >  Fix dependencies problems (identified by Samuel)

 >  package/Config.in            |  1 +
 >  package/apitrace/Config.in   | 14 ++++++++++++++
 >  package/apitrace/apitrace.mk | 17 +++++++++++++++++
 >  3 files changed, 32 insertions(+)
 >  create mode 100644 package/apitrace/Config.in
 >  create mode 100644 package/apitrace/apitrace.mk

 > diff --git a/package/Config.in b/package/Config.in
 > index 1ee60c1..097b487 100644
 > --- a/package/Config.in
 > +++ b/package/Config.in
 > @@ -216,6 +216,7 @@ source "package/weston/Config.in"
 
 >  comment "X applications"
 >  source "package/alsamixergui/Config.in"
 > +source "package/apitrace/Config.in"
 >  source "package/docker/Config.in"
 >  source "package/feh/Config.in"
 >  source "package/freerdp/Config.in"
 > diff --git a/package/apitrace/Config.in b/package/apitrace/Config.in
 > new file mode 100644
 > index 0000000..388b3e9
 > --- /dev/null
 > +++ b/package/apitrace/Config.in
 > @@ -0,0 +1,14 @@
 > +comment "apitrace needs a toolchain w/ C++"
 > +	depends on !BR2_INSTALL_LIBSTDCPP

This comment should also depend on _XORG7 so it only shows up if X11
support is enabled.

 > +
 > +config BR2_PACKAGE_APITRACE
 > +	bool "apitrace"
 > +	depends on BR2_PACKAGE_XORG7
 > +	depends on BR2_INSTALL_LIBSTDCPP
 > +	select BR2_PACKAGE_XLIB_LIBX11
 > +	help
 > +	  Trace and replay OpenGL and OpenGL ES APIs calls to/from a file. You 
 > +	  may install apitrace GUI from your distribution to inspect generated 
 > +	  traces.
 > +	  
 > +	  http://apitrace.github.io/

Some trailing spaces and too long help text lines.

I did a test build on uClibc which failed because it tries to use the
glibc specific __libc_dlsym symbol, so I made the package depend on
BR2_TOOLCHAIN_USES_GLIBC.

 > diff --git a/package/apitrace/apitrace.mk b/package/apitrace/apitrace.mk
 > new file mode 100644
 > index 0000000..c31a5b3
 > --- /dev/null
 > +++ b/package/apitrace/apitrace.mk
 > @@ -0,0 +1,17 @@
 > +################################################################################
 > +#
 > +# apitrace
 > +#
 > +################################################################################
 > +
 > +APITRACE_VERSION = c181b7fbf4b1c3912424761fec8ac7124640543a
 > +APITRACE_SITE = http://github.com/apitrace/apitrace/tarball/$(APITRACE_VERSION)

I've changed it to use the github helper.

Committed with these changes, thanks.

-- 
Bye, Peter Korsgaard


More information about the buildroot mailing list