[Buildroot] [PATCH 3 of 6 v2] linux: add support for custom Mercurial repository

Thomas De Schampheleire patrickdepinguin+buildroot at gmail.com
Mon Aug 12 10:54:10 UTC 2013

Hi Arnout,

On Mon, Aug 12, 2013 at 8:12 AM, Arnout Vandecappelle <arnout at mind.be> wrote:
> On 24/07/13 09:23, Thomas De Schampheleire wrote:
> [snip]
>> diff --git a/linux/Config.in b/linux/Config.in
>> --- a/linux/Config.in
>> +++ b/linux/Config.in
>> @@ -52,6 +52,12 @@ config BR2_LINUX_KERNEL_CUSTOM_GIT
>>         This option allows Buildroot to get the Linux kernel source
>>         code from a Git repository.
>> +     bool "Custom Mercurial repository"
>> +     help
>> +       This option allows Buildroot to get the Linux kernel source
>> +       code from a Mercurial repository.
>> +
>>   endchoice
>> @@ -62,24 +68,26 @@ config BR2_LINUX_KERNEL_CUSTOM_TARBALL_L
>>       string "URL of custom kernel tarball"
>> -     string "URL of custom Git repository"
>> -     depends on BR2_LINUX_KERNEL_CUSTOM_GIT
>> -     string "Custom Git version"
>> -     depends on BR2_LINUX_KERNEL_CUSTOM_GIT
>> +     string "URL of custom repository"
>  Given that string options can't be propagated from their legacy values,
> and since the name of an option isn't really that important, I'd keep
> the _GIT_ names for the mercurial options as well.
>  If we do rename the option symbol names, then I would make sure that it
> is propagated:
> + add a comment to the .legacy file so these hacks can be removed
> eventually.
>  Also, you have to change the symbol names in the defconfigs as well
> (there are already 10 uses of this symbol).

Thanks for your feedback on this series.

Regarding the choice of keeping the _GIT_ option names as-is, or
changing them with the appropriate legacy handling, I'd like to hear
the opinion of others.

I understand that the _GIT_ names make the legacy handling easier, but
I also feel it's awkward to have _GIT_ in your config file when you're
really using Mercurial. It seems like a hack to me. So my preference
would be to stick to the renaming as proposed in this patch series,
but with the additional default in linux/Config.in (and likewise for
uboot) as you suggested, deprecating this default later. In this case
I'll also change the defconfigs, as you correctly noted (thanks).

Best regards,

More information about the buildroot mailing list