[Buildroot] mdev.conf missing during kernel boot-up process?

Arun Reddy reddyac at gmail.com
Wed Jun 11 16:18:45 UTC 2008

I just finished a MIPS build and I seem to have a near-successful boot-up in
QEMU going. After mounting the root (ext2 filesystem) as ready only, the
boot up halts saying that it

cannot create directory '/dev/pts': File exists
/bin/sh: /proc/sys/kernel/hotplug: No such file or directory
mdev: /etc/mdev.conf: No such file or directory
mdev: /etc/mdev.conf: No such file or directory
mdev: /etc/mdev.conf: No such file or directory
mdev: mknod loop2: Read-only file system
/bin/hostname: invalid option -- F
Try '/bin/hostname --help' for more information.

I checked my BusyBox settings and mdev.conf support is enabled. It seems to
me that mdev.conf should be automatically generated for me, but after
mounting my harddisk image and checking inside of /etc, I don't see it. Is
this because it is supposed to be created after the root filesystem is
mounted during the boot-up process? Is it being restricted because I haven't
set rw access? I tried booting it up with rw set, but I still get the same
mdev.conf error. And when I try to boot it up again, it says that it can't
mount to my hda1 device because the kernel has unsupported optional features
set. The only way to try again properly is by remaking my harddisk image.

Anyone have any idea why mdev.conf is not being generated? Any specific
BusyBox setting I might be missing? Here's what I have set for mdev in


Thank you for any assistance you guys can offer!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.busybox.net/pipermail/buildroot/attachments/20080611/38110c1d/attachment-0002.htm 

More information about the buildroot mailing list