[Buildroot] Compiling gcc in the toolchain

Frank Ludwig ludwig.frank at gmail.com
Thu Dec 7 03:26:06 UTC 2006


I have been using a buildroot root jail to compile components for a smallish 
Linux system I am playing with, and it has so far been working great. With 
apparently one exception: I have not been able to produce a gcc executable 
that would in turn be able to create programs that would run inside the root 
jail (anywhere, actually). Has anyone tried with more success than I have? 
How did you pull it off?

I am doing i386 to i386 (with only uclibc making my system "special"), trying 
to compile gcc 3.4.2 (and some others), and the most common problem I run 
into is a gcc executable that will link to the libraries at addresses 

I don't think I should have to specify host/target (as the jail resembles the 
target), and get little difference if I do. One of the many config parameter 
sets I tried is that:

./configure \
	--prefix=/usr \
	--enable-shared \
	--enable-threads=posix \
	--disable-nls \
	--disable-multilib \
	--disable-__cxa_atexit \
	--with-system-zlib \
	--with-sysroot=/ \
	--enable-languages=c \

Any insight would be greatly appreciated!

(ludwig.frank at gmail.com)

More information about the buildroot mailing list